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TS REPORTSERVER

TS ReportServer takes output from Report-1V on the host and presents it graphically at the
workstation. It is fully integrated with VVIP but does not require that the graphical presentation be
installed or enabled, meaning it will also work when running your application in character mode.
You can also use TS ReportServer with Gateway for Windows.
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PATH DEFINITIONS AND CONVENTIONS

The paths noted in this manual vary depending upon the operating system.
vip-data-path is used to indicate the path where files requiring read and write access are located.

e On Windows Vista/Windows Server 2008/Windows 7/Windows 8/Windows Server 2012 the required
path is C:\ProgramData\Thoroughbred Software\TSI.

vip-user-path is used to indicate the path where user specific files requiring read and write access are
located.

e  On Windows Vista/Windows Server 2008/Windows 7/Windows 8/Windows Server 2012 the required
path is C:\Users\tbred2\AppData\Roaming\Thoroughbred Software.

vip-program-path is used to indicate the path where executable and some dll files are located.
e On all Window platforms the default path is C:\Program Files\TSI\Bin.

vip-system-path is used to indicate the path where Thoroughbred ini files and other system files that
require write access are located.

e On Windows Vista/Windows Server 2008/Windows 7/Windows 8/Windows Server 2012 the required
path is C:\ProgramData\Thoroughbred Software.

e  On other Window platforms this path may vary, typically it is C:\Documents and Settings\All
Users\Application Data\Thoroughbred Software.

2
Copyright 2021 Thoroughbred Software International, Inc.



SETUP

The Thoroughbred Environment includes the RPSERYV printer table. From the System
Administration menu select Printer Assignment. For more information see the Dictionary-1V
Administrator Guide. Assign any printer device (i.e. RS, LP, P1) to the RPSERV printer table.
The recommended printer device is RS. You will then need to modify your IPLINPUT file to
include this printer device.

For more information see the Thoroughbred Basic Customization and Tuning Guide.

IPLINPUT for Windows Basic:

DEV RS,4,.,.,., NUL
or
DEV RS,4,,..,, file-name

Where file-name is the name of any text file defined in your Thoroughbred Basic Environment
for example, basic-install-path\Thsc\RSText.txt

IPLINPUT for UNIX:

DEV RS,4,,,1,,,/dev/null
For more help on how to use the TS ReportServer
e Select vip-data-path\Tsi\Bin\Rps.hlp, or
e Select Help and then select Help Index from the TS ReportServer menu bar.
For more information see the Thoroughbred Basic Customization and Tuning Guide.
Creating and Sending Report-IV Output to TS ReportServer

TS ReportServer is included as a standard output device in the Dictionary-1V printer selection
prompt:

ISElect Printer ( LP PAL B3 PF PN ) :IRS I

When TS ReportServer is selected as the output device, the report will automatically be
displayed by the TS ReportServer on the client.
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&F Thoroughbred RPS Server - Samplel.rps = IEIIiI

File Edit ‘iew ©Options window Help

EEEEREC

OE-RCUST Sample System - Customer Listing Page:
09/20/96 ag:42 AM
Cust

Code --- Gontact -—— -——-———- Hame ---—- -———- City --——- St SR -- Sales —-
108188 Tex Rogers Toot-Your-Horn Port Lavaca TX AF 15,827 .88
188181 David Kelly Fix-W-Up Seadrift TA HP 16,253.36
188182 Sue Thompson Computer Inc. Hadison HJ JJd 16,628.84
188183 Robert Brock Today's Company Bridgevater HJ J5 16,951,084
180184 Sarah Smith ACHME Inc. Dayton HJ AF 17,222.36
100165 UWalter Snider Lumber Inc. Big Horn HD HP 17,442 00
188186 Dennis Gohlke 0K Development Port Lavaca Td JJd 17,609.96
180187 John Dworaczyk  Memory Lanes Victoria T® JS  18,3108.16
222221 TEHWP CU3TA TEMP CUSTH Port Lavaca Td 21 13,757.88
222222 TEHWP CUST2 TEMP CUST2 Port Lavaca TH 22 13,226 .85
222220 TEHWP CUSTA TEMP CUSTA Port Lavaca TH A 15,135.78
222222 Deleted custs Deleted custs 22 .88
|« |

|<|<| Page 1 | >|>I||

Ready [Page 1 [ ]

TS ReportServer can display multiple reports. Each report is displayed in a window contained by
one common TS ReportServer GUI Server window.

&F Thoroughbred RPS Server - Sampled.rps = IEllll

File Edt ‘iew Options window Help

EEIEEEET

|‘

OE

Lk oE =

I =) DE-RIMUH Sample System - Invoice Header

== B9/20/%6 69:49 AM

18

18 Invoice —————-— Company Hame------ ——| Date—— -—— Amount--- --— Credits-- --Payments—-

18

18 8066881 Toot-Your-Horn 81/12/96 241,93 .8 .88

28 0800802 Fix-M-Up 81/13/96 L7B.82 il .8

20 @08a8a3 Computer Inc. 81/14/96 684.38 .88 -a8

20 8008004 Today's Company 81/15/96 8B4 TF .ea .88

28 808885 ACHE Inc. 81/16/96 1871.3¢9 .88 .88

38 808886 Lumber Inc. 81/17/96 124419 .88 .88

38 806887 0K Development 81/18/96 14832.18 .8 .88

38 @0008688 Memory Lanes 81712796 1548 .33 il .8
a0e8a¢ TEMP CUSTH a1/28/%6 2208 .45 .88 -8 _|
g08818 TEWP CUsST2 81/21/96 2246 47 .88 ]
808811 TEWP CUSTA 81/22/96 2699.1¢9 .88 ]
808812 Toot-Your-Horn 81/23/96 2003.13 .88 .88 .
i 3

1<| <] Paget |>|>|||

Ready [Page 1 [ 4

Any report displayed by TS ReportServer can be saved locally on the client. By default, the file
is saved in TS ReportServer format (with the .rpt file extension). For more information on saving
and opening local report files please see "Save a Report” later in this manual.
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An application performing CONNECT REPORT can control the output device by pre-setting the
printer id. This allows the application to send the report output to the TS ReportServer without
user intervention.

If the TS ReportServer is available, Query-1V sends all terminal output to the TS ReportServer
for processing. Your application can duplicate this process. Query-I1V uses the following tests to
determine if the TS ReportServer is available:

Is the default output set to the terminal?
FID(0)

Does the Global variable RPSERV exist?
CGV("'RPSERV'")

Does the Workstation have GUI capabilities?

#IDVIP.GUI-ON=""Y"

If these tests determine that the TS ReportServer is available set the output device to the Global
variable RPSERV.

LET REPORT$[6]=cgv(*'RPSERV'")

CONNECT Report *‘report-name'’
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TS REPORTSERVER WINDOW

The main TS ReportServer GUI Server window is displayed when TS ReportServer is selected
as the output device on the host or when you select the TS ReportServer icon on the client from
the VIP program group.

& Thoroughbred RPS Server o [=[ o3

Fil= Options Help

|| B2| 22| ol

|<|<| Page 1 | >|>|||
Ready Page 1 ,_,WI_ v
File

Open an rps file
Print Setup to select the printer properties, etc.

Print Setup 20|

— Frinter
MName: Apple Lazerw/iter || NT Froperties. .. |
Status: Ready
Type: Aipple Lazerw/iter || NT w47.0
“Where:  LPTI:
Comment:

— Paper Orientation
Size: ILetter j &+ Puortrait
Source; |Automalically Select j " Landscape
Metwark. . | oK I Cancel |

Recent Files to select from the last files opened.

Exit TS ReportServer.
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Options

Check (display) or uncheck (remove) the Status Bar, Pagebar, and Toolbar from the TS
ReportServer window. See the graphic above to see where these are located.

Check Paged Scroll to scroll the last 100 pages of the report history.

Help
Access TS ReportServer help.

Open a Report

From the TS ReportServer window select the File menu and then select Open.

open x|

Lok ir I ) Reports j - I'j‘ -

Samplel.rps
SampleZ.rps
Sample3.rps
Sampled.rps
Samples.rps

File: name: | Open

Files of type: |Thomughbred Reparts [* rps) j Cancel |
v

NOTE: TS ReportServer can only open (display) files that have been saved in .rps format.
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The .rps files above are sample reports that are stored in vip-user-path\TSI\Reports. Select
Samplel.rps and the following report appears:

&F Thoroughbred RPS Server - Samplel.rps = IEIIiI

File Edit ‘iew ©Options window Help

EEEEREC

OE-RCUST Sample System - Customer Listing Page:
09/20/96 B2:42 A
Cust

Code --- Gontact -—— -——-———- Hame ---—- -———- City --——- St SR -- Sales —-
108188 Tex Rogers Toot-Your-Horn Port Lavaca T AF 15,827 .88
188181 David Kelly Fix-W-Up Seadrift TA HP 16,253.36
188182 Sue Thompson Computer Inc. Hadison HJ JJd 16,628.84
188183 Robert Brock Today's Company Bridgevater HJ J5 16,951,084
180184 Sarah Smith ACHME Inc. Dayton HJ AF 17,222.36
100165 UWalter Snider Lumber Inc. Big Horn HD HP 17,442 00
188186 Dennis Gohlke 0K Development Port Lavaca Td JJd 17,609.96
180187 John Dworaczyk  Memory Lanes Victoria T® JS  18,3108.16
222221 TEHWP CU3TA TEMP CUSTH Port Lavaca Td 21 13,757.88
222222 TEHWP CUST2 TEMP CUST2 Port Lavaca TH 22 13,226 .85
222220 TEHWP CUSTA TEMP CUSTA Port Lavaca TH A 15,135.78
222222 Deleted custs Deleted custs 22 .88
|«

|<|<| Page 1 | >|>I||

Ready [Page 1 [ ]

NOTE: The TS ReportServer can handle multiple reports as well as split screen viewing within a
report. See below.

Menus
File
Open an .rps file located in vip-user-path\TSI\Reports.
Close the currently highlighted report.
Save the currently highlighted report.
Save As an .rps or .txt file.
Print the currently highlighted report.
Print Preview of the report before printing.

Print Setup
Displays the dialog box below so you can select the printer, paper size, orientation, etc.
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rintsetun x|

— Printer

Marme: Apple Laseradfiter [| MT Properties... |

Status: Ready

Type: Apple Laserwiiter [ HT «47.0
“Where:  LPTH:

Cormmett:

— Paper Orientation

Size: I Letter j " Partrait

by
Source: IAutomaticalIy Select j e Landscape

Metwork. .. | oK I Cancel

Recent Files displayed are listed.
Exit TS ReportServer
Edit - Select Copy, Find or Select All
View — Select Zoom In, Zoom Out, or select the Font.

Options — Select to view any or all of the following: Toolbar, Pagebar, Status Bar or Paged
Scroll.

Window — Select to Cascade or Tile the windows. You can also Arrange Icons. This simply
means that when you minimize a report window, an icon for the report displays at the bottom of
the window (see below).

&F Thoroughbred RPS Server - Sample5.rps i =] ]

File Edt ‘iew Options window Help

=\ | &[] aln

| EE!SamplERBST[=TES | &8'Samplespsi-dl=lS|

1<| <] Paget |>|>|||

Ready [Page 1 [ ]
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and you move one of the "icons" (see below).

& Thoroughbred RPS Server - SampleS.rps - |E||1|

File Edit View Options ‘Window Help

=[] B2 52| ol

PR sioix|

o sioix
|<|<| Page 1 | >|>|||

Ready [Page 1 [ o )

Select Windows-> Arrange Icons to place them back at the bottom of the screen (see below).

&F Thoroughbred RPS Server - Sample5.rps = IEllll

File Edt ‘iew Options window Help

=B B S(2| alal

CEETET siolx||FESREYT sio0/x|

1<|<|  Paget |>|>|||

Ready [Page 1 [ 4

Help — Select the Help index or find the version number (About).
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Toolbar

The Toolbar can be moved using normal Windows procedures. The following buttons are
available from the Toolbar:

ﬁl El Open and Save

Open — This button allows you to open an .rps file to edit.

Save — This button allows you to save the file (the first time opened) or to save edits to the
report.

NOTE: From the File menu you can save the report as *.rps, or *.txt files. From the Edit menu
you can copy the report to the clipboard, make changes to the report and save, or exit without
saving. For more information see Saving a Report.

| Copy

Copy — This button allows you to copy the edited file to the clipboard.

%l 'ﬁ) | Print and About

Print — This button allows you to print the edited file.

About — This button displays the TS ReportServer version.

| M | Font Size and Find

Font Size — This button allows you to zoom in or out in the report.
Find — This button allows you to search the file for characters, numbers or words.
Split Screen Viewing

With TS ReportServer you can split reports both vertically and horizontally. Each pane contains
a set of scroll bars allowing each to be scrolled independently of the other. It supports a total of
four panes: two vertical split panes and two horizontal split panes.
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=
File Edit View Options ‘Window Help
EEEERE)
=101 x|
OE-RCUST Sample System - Customer Listing Page: 1
09/20/96 B9:40 A —
Cust
Code --- Gontact -—— -——-———- Nameg ---—-—- -———- City --—- 3t SR -- 5ales —-
188188 Tex Rogers Toot-Your-Horn Port Lavaca TR AF 15,827 .68
180181 David Kelly Fix-H-Up Seadrift TH HP 16,253.36
188182 Sue Thompson Computer Inc. Hadison HJ 16,628 .04
108183 Robert Brock Today's Gompany Bridgewater NJ JS  16,951.04
188184 Sarah Smith ACME Inc. Dayton HJ AF 17,222.36
1008105 Walter Snider Lumber Inc. Big Horn HD HP 17,442 .88
180186 Dennis Gohlke 0K Development Port Lavaca T8 JJ 17,689.96
180187 John Dworaczyk  Hemory Lanes Uictoria TZ JS  18,318.16
222221 TEHWP CUSTA TEMP CUSTH Port Lavaca T 21 13,759.88
2227222 TEMP CUST2 TEMP CUST2 Port Lavaca Td 22 13,226.85
22272 TEWP CUSTA TEMP CUSTA Port Lavaca T JJd 15,135.78
222222 Deleted custs Deleted custs 22 -80
178,366.35
-
Kl | 4
|<|<| Page 1 | >|>|||
REady Page 1 lilmli v

Grab for horizontally
split screen.

To create two vertical panes
Grab the little button on top of the vertical scroll bar (see graphic above) and then drag your

mouse

= Thoroughbred RPS Server - Samplel.rps

Wiew  Opkions

File  Edit

down.

Window  Help

=10l

=\ d| & 52| aln

~oix]
|0 CUST Sample System - Customer Listing Page: 1 =
09/20/96 89:49 AM

Cust

Code --- Contact ——- ——--—-- Mame ----- ----—- City ---- St SR - Sales —-
188188 Tex Rogers Toot-Your-Horn Port Lavaca TR AF 15,827 .68
180181 David Kelly Fix-H-Up Seadrift T HP 16,253.36
188182 Sue Thompson Computer Inc. Hadison HJ 16,628 .04
188183 Robert Brock Today's Company Bridgewater HJ JS  16,951.84
188184 Sarah Smith ACME Inc. Dayton NJ AF 17,222.36
100185 UWalter Snider Lumber Inc. Biq Horn HD HP 17,442 .68 ‘:J
OE-RCUST Sample System - Customer Listing Page: 1 &
82/28/96 B9:42 AW

Cust

Code --- Gontact -—— -——-———- Hame ---—-—- -——- City --——- St SR - Sales —-
180188 Tex Rogers Toot-Your-Horn Port Lavaca T AF 15,827 .68
188181 David Kelly Fix-H-Up seadrift T& HP 16,253.36
188182 Sue Thompson Computer Inc. Hadison HJ JdJd 16,628.04
188183 Robert Brock Today's Company Bridgevater HJ J3 16,951.04
180184 Sarah Smith ACHME Inc. Dayton HJ AF 17,222.36
180185 Ualter Snider Lumber Inc. Big Horn HD HP 17,442 .88 —
1808186 Dennis Gohlke 0K Development Port Lavaca TX JJ 17,689 .96 -
i i
|<|<| Page 1 | >|>|||
Ready Page 1 UM v
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You now have two vertical panes that can be scrolled independently. To create a single pane,

reverse the procedure used to create two panes.

To create two horizontal panes

Grab the little button on the left of the horizontal scroll bar (see graphic at the beginning of this

section) and then drag your mouse to the right.

& Thoroughbred RPS Server - Samplel.rps

File Edit View Options ‘Window Help

=10l

EEEEREY)

R
|0E—RCUST Sample System |0E—RBUST Sample System - Cus
09/20/96 09/20/96 —
Cust Cust
Code --- Contact ——— -————-—- Name | Code  -—- Contact -—— -——————- Name ---
188188 Tex Rogers Toot-Your-Ho (188188 Tex Rogers Toot-Your-Horn
180181 David Kelly Fix-H-Up 166181 David Kelly Fix-H-Up
188182 Sue Thompson Computer Inc (188182 Sue Thompson Computer Inc.
188183 Robert Brock Today's Comp (188183 Robert Brock Today's Company
188184 Sarah Smith ACME Inc. 188184 Sarah Smith ACME Inc.
180185 Walter Snider Lumber Inc. [186185 Walter Snider Lumber Inc.
180186 Dennis Gohlke 0K Developme (188186 Dennis Gohlke 0K Development
188187 John Dworaczyk Hemory Lanes (188187 John Dworaczyk Hemory Lanes
222221 TEHWP CUSTA TEMP CUSTH 222221 TEMWP CUSTA TEMP CUSTH
2227222 TEMP CUST2 TEMP CUST2 222222 TEMP CUST2 TEMP CUST2
22272 TEWP CUSTA TEMP CUSTA 22ZZZA TEMWP CUSTA TEMP CUSTA
222222 Deleted custs Deleted cust [£2222Z Deleted custs Deleted custs
-
I — 2l | oz
|<|<| Page 1 | >|>|||
Ready |Page 1 I_IW|_4

You now have two horizontal panes that can be scrolled independently. To create a single pane,
reverse the procedure used to create two panes.
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To create four panes

Simply perform the two procedures above and you will have a split screen similar to the one

below:

& Thoroughbred RPS Server - Samplel.rps

File Edit View Options ‘Window

Help

=[] B2 52| ol

I<|<|

Page 1 | >|>||

-lojxi
PE RCUST Sample SysteluE—RCUST Sample System - Cust
09/20/96 09/20/96

Cust Cust

Code --= Contact ——— -——-———- Ma| Code --=- Gontact ——— -—-———- Mame -----
188188 Tex Rogers Toot-Your- [188188 Tex Rogers Toot-Your-Horn
100181 David Kelly Fix-M-Up [188181 David Kelly Fix-H-Up

188182 Sue Thompson Computer I 188182 Sue Thompson Computer Inc.

188183 Robert Brock Today's Co 188183 Robert Brock Today's Company
10018% Sarah Smith ACME Inc. [18@184 Sarah Smith ACME Inc. =
ME-RCUST Sample Syste [DE-RCUST Sample System - Cust «
09/20/96 09/20/96

Cust Cust

Code --- Contact ——— -————-—- Na| Code --- Contact -—— -—--——-- Name ---—-—-
188188 Tex Rogers Toot-Your- 188188 Tex Rogers Toot-Your-Horn
180181 David Kelly Fix-M-Up [188181 Dawvid Kelly Fix-H-Up

188182 Sue Thompson Computer I 188182 Sue Thompson Computer Inc.

100183 Robert Brock Today's Co 188183 Robert Brock Today's Company
188184 Sarah Smith ACHME Inc. [188184 Sarah Smith ACHE Inc.

“] P P - '_‘l e, S i -

Ready

|Page 1

The frame can be resized using normal Windows procedure. Grab any side or corner and enlarge

or decrease the size.

Copyright 2021 Thoroughbred Software International, Inc.
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Save a Report

A report can be saved by selecting File menu Save, by closing a report window or by closing the
main TS ReportServer window. The following message is displayed for the top report displayed
in the main TS ReportServer window:

El Thoroughbred RPS Server - Sample System - Invoice Header EI =2
File Edit View Options Window Help

(W] | &(?] a4

[ Sample Systern - Customer Listing o | =

: El 1 sample Systern - Inventory File Listing

Sample rn - Sales Rep Listin

[=] sample System - Invoice Header
2
|((-RIN‘JH
B2/08,18

Invoice ----- @ Save changes ko Semple Spstem - Inveics Header?

pEEEAL Toot-
BEOEEZ Fix-M
e0e0a3 Compu
pEEOES Today
BEEOAS ACME
BE0EE5 Lumber Inc. B9,/08/09 1244,19

|+] |

A Ma Mo b al Cancel I

I<|<| Pagz 1 | >|>I||

Ready Page1 B

Yes — Will save the report prompting for a file name, location and a file extension.
No — Will close the report without saving it.

No to all — Will close the current report without saving and will not prompt you to save when
closing other report windows. This eliminates the need to respond No for each opened report.

Cancel — Closes the save dialog and without doing anything.
TS ReportServer allows you to save a report in two formats.
Saving as a Thoroughbred Reports file (*.rps)

» From the File menu select Save. The report file will be saved to the default folder. The
default folder location is set from the WorkStation Manager Default Directories tab. If none
is supplied report files will be saved in vip-user-path. For more information please see the
WorkStation Manager Manual.
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e From the File menu select Save As and then you can save the report as a TS ReportServer
file (.rps) in the folder of your choice.

Saving in a different format

From the File menu select Save As and then you can save the report as a text file (txt) in the
folder of your choice.

NOTE: TS ReportServer can only display reports that are saved in .rps format. Once a report is
saved as a text file, TS ReportServer cannot be used to open it.

Copying to the Clipboard

From the Edit menu select Copy and then you can Paste the report in any DDE compliant
application.

16
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GATEWAY FOR WINDOWS

The host program requires a simple communication. Each page uses a single CALL to the
program RPSCOM.

Terminate each line on the page with:

CRLF (CHR(13)+CHR(10))

Terminate each page with:

FF (CHR(12))
page-of-data'" + CHR(12)

Prefix the CRLF at the end of each line with a CHR(11) to indicate a heading line.

CHR(11) + CRLF

The TS ReportServer displays a dialog status box as each page is received and processed.
Append the following instruction to the final page of the report:

""page-of-data-for-last-page"™ + "[.END.]"

The TS ReportServer immediately displays the report. It allows complete user manipulation and
processing of the report, including forward and backward scrolling, printing to a file, and saving
to a file.

Example

The following example illustrates the simplicity of the host programming required to invoke TS
ReportServer.

00010 REM &REM&
00020 BEGIN;

DIM M$[5];
IGateway call string
LINEEND$=CHR(13)+CHR(10), 1End of
line indicator
HEADL INEEND$=CHR(11)+L INEEND$, 1End of heading
indicator
LASTS="[-END.]" ILast

page indicator

17
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00100 M$[1]="14",
M$[2]="RPS",
M$[3]=""SYSTEM",
M$[5]="[-.LOAD.]";

CALL "RPSCOM',M$[ALL];

IF M$[O]<>"."
GOTO 9000

ELSE
M$[1]="P", IDefine Report Message:
MS[5]=""**"+ 1(1,2)="rx*"

"UTSAMPLE"+ 1(3,8)=Report name

1(11,40)=Report Description
"Gateway for Windows Test Report "+
080"+ 1(51,3)=Report
width
060" ; 1(54,3)=Number of
lines/page
CALL "RPSCOM" ,M$[ALL]

00200 REM PAGE1

00210 P$=""",
P$=P$+" HEADING LINE 1 "+HEADLINEENDS$,
P$=P$+" HEADING LINE 2 ""+HEADLINEENDS$,
P$=P$+"DETAIL LINE 1 "+LINEEND$,
P$=P$+"DETAIL LINE 2 "+LINEENDS,
P$=P$+"DETAIL LINE N "+LINEENDS,
P$=P$+CHR(12);
GOSUB 1000

00220 REM PAGE2 THRU PAGEN

00230 P$="",
P$=P$+" HEADING LINE 1 "+HEADLINEENDS,
P$=P$+" HEADING LINE 2 "+HEADLINEENDS,
P$=P$+"DETAIL LINE 1 *+LINEENDS,
P$=P$+"DETAIL LINE 2 *+LINEENDS,
P$=P$+"DETAIL LINE N "+LINEENDS$,
P$=P$+CHR(12) ;
GOSUB 1000

00240 REM LAST PAGE

00250 P$=""",

P$=P$+'" HEADING LINE 1 "+HEADLINEENDS,
P$=P$+'"" HEADING LINE 2 ""+HEADLINEENDS$,
P$=P$+"DETAIL LINE 1 "+LINEENDS,
P$=P$+""DETAIL LINE 2 "+LINEEND$,
P$=P$+""DETAIL LINE N "+LINEEND$,
P$=P$+LASTS;

GOSUB 1000;
GOTO 9000

01000 M$[5]=P%;
CALL ""RPSCOM",MS$[ALL];
RETURN

09000 RUN "'***
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MULTI-LANGUAGE

For more information about Multi-Language, see the Dialog, Message, and MenuBar Text
Translations section in the Multi-Language for VIP.
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